Home>

Currently, I want to create an application on the Web using an open source framework called hifive, but it is said that it cannot be used without jQuery.
So I tried to download jQuery3.3.1 and use it together with hifive, but the application I created doesn't respond.

HTML
<! doctype html>
<html>
    <head>
        <meta charset = "UTF-8">
        <script src = "jquery.js"></script>
        <script src = "ejs-1.0.h5mod.js"></script>
        <script src = "h5.js"></script>
        <!-Load the js file created here->
        <script src = "step3.js"></script>
        <title>hifive Hello World</title>
    </head>
    <body>
        <div>
            <input type = "button" value = "hello world!" />
        </div>
    </body>
</html>


↓ step3.js

$(function () {
    var helloWorldController = {
        __name: 'HelloWorldController',
        '#btn click': function () {
            alert ('Hello, World!');
        }
    };
    h5.core.controller ('# container', helloWorldController);
});


In addition, jQuery and hifive that have been downloaded are saved in the same folder.

Is it possible to use hifive due to the difference in version? Or is my file path written in the wrong way?
In any case, it would be greatly appreciated if you could guide me if there is a wrong place.
I would also appreciate if you could provide a URL that would be helpful.