Home>

I'm trying to install and use the following URL module with pod'PopupWindow&apos ;.
https://github.com/shin8484/PopupWindow

However, the contents of the installed PopupWindow and the contents cloned from git are different. Some of them are the same, but there were not enough people in the pod, and some files were misspelled. Why is this?

By the way, the pod file was updated as follows.

platform: ios, '10 .0 '
target 'life_log' do
  use_frameworks!

  pod 'PopupWindow'

end

------------ Addition ---------

I tried to specify the version as follows.

platform: ios, '10 .0 '
target 'life_log' do
  use_frameworks!

  pod 'PopupWindow', '~>0.2.17'

end


Then I get the following error

[!] CocoaPods could not find compatible versions for pod"PopupWindow" ;:
In Podfile:
PopupWindow (~>0.2.17)

None of your spec sources contain a spec satisfying the dependency:PopupWindow (~>0.2.17).

You have either:

  • mistyped the name or version.
  • not added the source repo that hosts the Podspec to your Podfile.

Note: as of CocoaPods 1.0,pod repo updatedoes not happen onpod installby default.

  • Answer # 1

    If you search

    https://cocoapods.org/, the version is0.1.0, so this is probably the latest version. (In addition, it seems that it will not be maintained on CocoaPods because it will fly to GitHub if selected)

    It seems that you can install any branch/tag on GitHub by directly specifying the URL of GitHub.

    pod'PopupWindow&apos ;,: git =>'https: //github.com/shin8484/PopupWindow.git'

    Click here for details.
    From a podspec in the root of a library repo.