Home>

Thanks for your attention.

C: \ web2 \ www \ download \
I want to add Basic authentication to the site uploaded by

". htaccess"

AuthUserFile .htpasswd
AuthGroupFile/dev/null
AuthName "input your id and passwd"
AuthType Basic
require hoge piyo

". htpasswd"

test: 0azdkgMrMvFL6


I uploaded it with
I got the following error.

Is this an error that you can't do unless you enable it in Apache's httpd.conf?
Or is this bad?

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Apache/2.2.22 (Debian) Server at www.hogehoge.co.jp Port 80

I'm very sorry for the basics, but I will contact you.

  • Answer # 1

    If AuthUserFile is a relative path, it seems to be a relative path from ServerRoot.
    Please describe the absolute path once.

  • Answer # 2

    No way

    require hoge piyo


    Isn't it as it is?

    require valid-user


    Is n’t it?

    Like packet1024

    AuthUserFile .htpasswd


    Describe with relative path from ServerRoot or relative path from OS root.

  • Answer # 3

    Thank you for your comments.

    It seems that .htaccess was not enabled on the server after all
    I asked the server administrator to enable it.

    Thank you for your comments.