Home>

Because i am a beginner just starting out as a hobby, it may be ugly, but I hope you can read it.

I would like to install postfix on the system that will be implemented in MariaDB10.1.35.
Mariadb-libs-1: 5.5.56-2.amzn2.x86_64 installed along with postfix during installation
I have a conflict.
Does this mean that coexistence is impossible? I'm wondering if the system should match 5.5.56.
The search also describes how to use the two versions together, and that is also under consideration.

Error message
etc/my.cnf from install of MariaDB-common-10.1.35-1.el6.x86_64 conflicts with file from package mariadb-libs-1: 5.5.56-2.amzn2.x86_64
file /usr/lib64/mysql/plugin/dialog.so from install of MariaDB-common-10.1.35-1.el6.x86_64 conflicts with file from package mariadb-libs-1: 5.5.56-2.amzn2.x86_64
Tried

-Remove existing MariaDB once, install postfix, and then yum (same error message just in reverse order)
・ Add repository from official website and sudo yum update

Supplemental information (FW/tool version etc.)

OS: Amazon Linux 2

  • Answer # 1

    There may be a problem because Amazon Linux 2 contains a package for RHEL/CentOS 6 that is not guaranteed to be compatible.

    Downloads.mariadb.com doesn't have a repository for Amazon Linux 2, so https://downloads.mariadb.com/MariaDB/mariadb-10.1.35/bintar-linux-systemd-x86_64/ It may be good to extract and use the tar.gz of, or install mariadb-10.2 from amazon-linux-extras.

Related articles