Home>

Rubi on rails environment construction

Please write your question in detail here.
Sorry for rudimentary
I'm building an environment for rubyonrails now,
https://kapi-travel.com/programing/%E3%80%90windows10%E3%80%91ruby-on-rails%E7%92%B0%E5%A2%83%E6%A7%8B%E7%AF % 89% EF% BC% 88ruby-2-4-4-1-rails-5-2-0% EF% BC% 89/
I made it while watching
It didn't work when I thought about launching rails server.
I want you to tell me how to improve

Error message
1: from c: /Ruby/rails/myapp2/vender/bundle/gems/activesupport-5.2.1/lib/active_support/dependencies.rb: 287: in `block in require '
c: /Ruby/rails/myapp2/vender/bundle/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb: 32: in `require ': cannot load such file-sqlite3/sqlite3_native ( LoadError)
Applicable source code
Source code
Tried

Please describe what you tried for the problem here.

Supplemental information (FW/tool version etc.)

Please provide more detailed information here.

  • Answer # 1

    Hello

    It seems that such an error appears when you put rails 5.2.0 or higher.
    https://StackOverflow.com/questions/130133

    I had the same problem in the past and tried it through various sites, but it didn't work.

    I think the easiest way is to lower the rails version to rails5.1 or lower, or use something other than sqlite as the database.

    I am currently using rails5.2.0 with mysql.

Related articles