Home>

Thanks for your attention.

Migrating fromWordpress2.8to4.9.
Wordpress and database tables have already been built,
Only the contents of the database will be transferred.

I'm in trouble because I've never encountered a situation in the middle of my work.
Please tell me if there is a solution.

Error message

After the article data has been migrated, the management page login page was opened for confirmation.
The messagePlease update the database"is displayed and updated.

After logging in to the administration screen, thesite TOP screenis restored.

Tried

-Changesiteurlandhometo the destination URL in thewp-optionstable of the destination database.

・ Change the contents of wp-config.php

define ('DB_NAME', 'migration URL');
define ('DB_USER', 'New database username');
define ('DB_PASSWORD', 'New database password');
define ('DB_HOST', 'new server hostname');
Supplemental information (FW/tool version etc.)

Before migration
Wordpress 2.8.6
MySQL 5.5.41

After migration
Wordpress 4.9
(The detailed version cannot be confirmed because the dashboard cannot be seen)
MySQL 5.5.41

Append

When I checked the log, I got the following message:

error.log

[error] [client xxx.xxx.xxx.xx] File does not exist: /hoge/swfobject.js, referer: https://hoge.com/hoge/
 [error] [client xxx.xxx.xxx.xx] File does not exist:/hoge/sitemanager, referer: https://hoge.com/hoge/


access.log

"POST /hoge/wp-login.php HTTP/1.1" 302-"https://www.hoge.com/hoge/wp-login.php?redirect_to=https%3A%2F%2Fwww .hoge.com% 2Fhoge% 2Fwp-admin% 2F&reauth = 1 "" Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36 "
"GET/hoge HTTP/1.1" 301 237 "https://www.hoge.com/hoge/wp-login.php?redirect_to=https%3A%2F%2Fwww.hoge.com%2Fhoge%2Fwp-admin%2F&amp ;reauth = 1 "" Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36 "
"GET /hoge/swfobject.js HTTP/1.1" 404-"https://www.hoge.com/hoge/" "Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0. 3239.132 Safari/537.36 "
"GET/hoge/HTTP/1.1" 200 31811 "https://www.hoge.com/hoge/wp-login.php?redirect_to=https%3A%2F%2Fwww.hoge.com%2Fhoge%2Fwp-admin% 2F&reauth = 1 "" Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36 "
"GET /hoge/swfobject.js HTTP/1.1" 404-"https://www.hoge.com/hoge/" "Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0. 3239.132 Safari/537.36 "
  • Answer # 1

    Transfer to WordPress 2.8.6 as the verification environment, stop all plug-ins, return the theme to the default one, and upgrade the version that is not far away (take steps 3.1 or 3.4, etc.) How about seeing it?

    【Japanese «Release — WordPress】
    https://en.wordpress.org/releases/

    There is a possibility that you can access by deleting all .htaccess.

  • Answer # 2

    Finally, we decided to start all over again.
    Thank you for your response.