Home>

Reference site

Cannot start applications using WEBrick.

16: from C: /Ruby25-x64/lib/ruby/site_ruby/2.5.0/bundler.rb: 114: in `require '
        15: from C: /Ruby25-x64/lib/ruby/site_ruby/2.5.0/bundler/runtime.rb: 65: in `require '
        14: from C: /Ruby25-x64/lib/ruby/site_ruby/2.5.0/bundler/runtime.rb: 65: in `each '
        13: from C: /Ruby25-x64/lib/ruby/site_ruby/2.5.0/bundler/runtime.rb: 76: in `block in require '
        12: from C: /Ruby25-x64/lib/ruby/site_ruby/2.5.0/bundler/runtime.rb: 76: in `each '
        11: from C: /Ruby25-x64/lib/ruby/site_ruby/2.5.0/bundler/runtime.rb: 81: in `block (2 levels) in require '
        10: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb: 29: in `require '
         9: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb: 20: in `require_with_bootsnap_lfi '
         8: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/loaded_features_index.rb: 65: in `register '
         7: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb: 21: in `block in require_with_bootsnap_lfi '
         6: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb: 21: in `require '
         5: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/sqlite3-1.3.13-x64-mingw32/lib/sqlite3.rb: 2: in `<top (required)>'
         4: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/sqlite3-1.3.13-x64-mingw32/lib/sqlite3.rb: 6: in `rescue in<top (required)>'
         3: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb: 287: in `require '
         2: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb: 253: in `load_dependency '
         1: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb: 287: in `block in require '
C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb: 32: in `require ': cannot load such file- sqlite3/sqlite3_native (LoadError)
  • Answer # 1

    Hello

    I have had the same problem in the past, but it seems that this error appears when rails is 5.2 or higher.
    I couldn't solve the problem fundamentally, but when I create an application usingmysqlinstead ofsqliteHow about being done like that?

    Since rails 5.1 and below did not show such an error, I think that it is one to try to lower the version.