Home>

As the title suggests, I am trying to connect to the Rasp Pi using the host name with VNC Viewer (RealVNC).
Device used is Windows 10, Rasp Pi 2

Error message

I just typed raspi.local in VNC Viewer with host name "raspi"

getaddrinfo:
The requested name is valid, but the requested type of data was not found.
(11004)


Error message appears and VNC connection using the host name is not possible.

-ssh and VNC are enabled on the Rasp Pai side.
-The host name was confirmed by typing "hostname" on the console of Raspai.
-Confirm that/etc/hostname and/etc/hosts are also edited.
-Confirm that avahi is installed with $sudo apt-get install avahi-daemon.

・ Windows10 so install iTunes and update to the latest version.
-Check that Task Manager's service tab, Bonjour Service is running.

-The same error content when trying to type raspi.local: 5900, raspi.local: 5901, raspi.local: 1.
・ As soon as I typed in ip, I was able to access and operate Rasp Pie from VNC Viewer.

・ Throwing ping raspi.local,
"""
The host raspi.local was not found in the ping request. Check the host name and try again.
"""

Supplemental information (FW/tool version etc.)

I tried a lot, but I didn't know why it didn't work, so I asked a question.
Isn't it possible without Rasppie 3 ??

If i get a drastic answer, I'm happy, but it's also helpful to just point out where the settings are wrong (we will revise the settings)

  • Answer # 1

    I did a lot of self-solving.

    https://blog.surume.tk/windows-bonjour-install/
    Download the iTunes installer from apple referring to the site in ↑,
    Install only Bonjour

    On the task manager, restart the Bonjour service

    You can now do it while you are playing with the above.
    Thank you to all who responded!

  • Answer # 2

    Is raspi.local registered in DNS?
    If you are not registered, you cannot connect from Windows.
    Is there anything wrong with connecting with an IP address?

    If you really want to access raspi with the name raspi.local from Windows
    It is necessary to add raspi.local and IP address correspondence table to hosts.

    Please ask some questions and check the operation.

    Does ping/VNC work with direct Raspai IP address specification?
    (If it does not work, you may need to check the router settings.)

    On the rasp pie side, install the related tools withsudo apt-get install avahi-utils,
    Can I see the surrounding information withavahi-browse -a -t?

    To check if there is a problem with avahi's behavior or manually changing hostname
    Try changing the hostname and using the defaultraspberrypi.localto see if you can ping it.
    If it works, instead of editing the file directly,
    Insudo raspi-config, change the host name with 2 Network Options>N1 Hostname, reboot and try again.

    Please tell me which Windows 10 version you have. (I think that something like Version 1709 (OS Buils.16299.1146) is written in the window that appears by typingwinver[Enter] around the address bar of Explorer)