Home>

Updated to Xcode11.2.1.

Perhaps Podfile has affected it, and what was built in Xcode 11.2 can no longer pass.
I get the following error:

Addition:
I tried to create a new project, installed Alamofire 4.8.2 (same version as the buggy project) and built it, but it worked without problems.
Maybe not due to Alamofire version.

unknown>: 0: error: module map file '/Users/xxx/Library/Developer/Xcode/DerivedData/Build/Products/Debug-iphonesimulator/Alamofire/Alamofire.modulemap' not found
<unknown>: 0: error: module map file '/Users/xxx/Library/Developer/Xcode/DerivedData/Build/Products/Debug-iphonesimulator/Alamofire/Alamofire.modulemap' not found
2 errors generated.
<unknown>: 0: error: failed to emit precompiled header '/Users/xxx/Library/Developer/Xcode/DerivedData/Build/Intermediates/PrecompiledHeaders/ObjectiveC_Bridging_Header-swift_G3WBCCN69QCA-clang_1ZMCMFHEN997W.pch' for bridging header '/ Usersxxx iOSApp/projectapp/projectapp/ObjectiveC_Bridging_Header.h '

Podfile

# Uncomment the next line to define a global platform for your project
# platform: ios, '11 .0 '
target 'projectapp' do
  # Comment the next line if you're not using Swift and don't want to use dynamic frameworks
  use_frameworks!
  # Pods for projectapp
  pod 'Alamofire'
  pod 'AlamofireImage', '~>3.5'
  pod 'Crossroad'
  pod 'FacebookCore'
  pod 'FacebookLogin'
  pod 'FacebookShare'
  target 'projectappTests' do
    inherit!: search_paths
    # Pods for testing
  end
  target 'projectappUITests' do
    inherit!: search_paths
    # Pods for testing
  end
end
post_install do | installer |
  installer.pods_project.targets.each do | target |
    target.build_configurations.each do | config |
      config.build_settings ['SWIFT_VERSION'] = '4.2'
    end
  end
end

By the way, there seems to be a new version of Alamofire.
Perhaps the following versions are compatible with Xcode11.2.1.

pod 'Alamofire', '~>5.0.0-rc.3'

However, it seems that the latest version of AlamofireImage is compatible with Alamofire 4.8, and it seems that the latest version of Alamofire cannot be inserted.

$pod install --repo-update
[!] CocoaPods could not find compatible versions for pod "Alamofire":
  In Podfile:
    Alamofire (~>5.0.0-rc.3)
    AlamofireImage (~>3.5) was resolved to 3.5.2, which depends on
      Alamofire (~>4.8)


I hope it can be solved by just setting up Xcode, whether it is a problem on Cocoapods. . .
What is the cause? Thank you.