Home>
Content

Apache does not start even if you click "Start Server" in MAMP.
Can someone please tell me more about you? Thank you.

Error log

C: \ MAMP \ logs \ apache_error.log

[Fri Nov 22 16:52:00 2019] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri Nov 22 16:52:01 2019] [warn] pid file C: /MAMP/bin/apache/logs/httpd.pid overwritten-Unclean shutdown of previous Apache run?
[Fri Nov 22 16:52:01 2019] [notice] Digest: generating secret for digest authentication ...
[Fri Nov 22 16:52:01 2019] [notice] Digest: done
[Fri Nov 22 16:55:37 2019] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri Nov 22 16:55:38 2019] [warn] pid file C: /MAMP/bin/apache/logs/httpd.pid overwritten-Unclean shutdown of previous Apache run?
[Fri Nov 22 16:55:38 2019] [notice] Digest: generating secret for digest authentication ...
[Fri Nov 22 16:55:38 2019] [notice] Digest: done

▼ Screen capture

localhost is also inaccessible.

Settings/work environment

▼ Settings screen capture

MAMP version: 4.1.1
OS: Windows10 (64bit)

I tried the following method but could not solve it.

▼ Disable IIS on Windows 10
https://qiita.com/k_saito/items/fd26eb74d5b74e7d88a3#%E5%95%8F%E9%A1%8C%E3%81%AE%E7%B5%82%E6%81%AF
* In the initial setting of Windows10, port number 80 is occupied, so we solved it but it was not effective.

▼ Comment out mod_perl and disable it
https://neco-fly.com/2018/07/17/mamp/

in C: \ MAMP \ conf \ apache \ httpd.conf I commented outLoadModule perl_module modules/mod_perl.sobut it had no effect.

▼ Uninstall XAMPP
XAMPP that was not used just in case was uninstalled using uninstall.exe in the directory.
This also had no effect.

▼ Windows 10-Firewall-Allow communication on specific port numbers
https://pc-karuma.net/windows-10 -firewall-open-port/
I configured to allow port 80, but it had no effect.

  • Answer # 1

    Are you trying to use HTTPS without an SSL certificate?

    You should check
    (I don't usually use MAMP, so I guess it's not true)
    Find out where the MAMP Apache httpd.conf file is located
    (I wonder if there is a MAMP/conf folder)
    Search for the word SSL,
    Comment out all the parts that have a description like "SSLEngine on", or
    If you comment out a line such as "LoadModule ssl_module" line by line
    I wonder if it can be improved.