I'm new to programming.
Windows 7 Professional
On a 64-bit operating system
I want to download, install, and run Python3.X correctly.

We have examined and verified various books, this site, etc.
Even if you install a 64-bit program
Even if you check the operation at the command prompt, an error will occur.

Error message
C: \ Users \ user>python
'python' is an internal or external command,
It is not recognized as an operable program or batch file.
Applicable source code
C: \ Users \ user>python

(After confirming that the system type is 64 bit in the control panel system)
After uninstalling the 64-bit program,
Somehow it worked when I installed the 32-bit program.
We were able to install third parties with the pip install module.

I tried installing both for 64-bit and 32-bit, but
The result also showed an error for 64-bit.

Here is the question.

1. Why does the above error occur in a 64-bit program?

2. Why does the system work with 32-bit programs even though it is 64-bit?

3.3 Another error will occur when proceeding with a 32-bit program.
Could it be caused by a 32-bit program?


System type: 64-bit operating system
Where to get the installer: https://www.python.org/downloads/release/python-380/
Details of installed steps:
1. Uninstalling buggy Python 3.X and Python Launcher
2. Install from "Windows X86-64 executable installer" from the above installer location
3. Run the application
("Python-3.8.0-amd64" file is stored in C: \ Users \ user \ Downloads)
4). Check [Add Python 3.7.5 to PATH] during installation
5. After installation is complete, move to "Edit" of the user environment variable (U) of the environment variable user due to an error at the above command prompt
6). Add the following folders to Path (each is connected with a semicolon so that there is no error)
C: \ Users \ user \ AppData \ Local \ Programs \ Python \ Python37 \ Scripts
C: \ Users \ user \ AppData \ Local \ Programs \ Python \ Python37
(The variable name has been changed to "Path" or "PATH", but there is no change)
(I thought it might be caused by setting the path environment variable itself, but I deleted it, but that's still not possible)

  • Answer # 1

    You just don't go through the path
    Should I go around with "Pass Windows path"?

  • Answer # 2

    First, make sure that you are using a 64-bit OS.

    I want to check if my computer is 32-bit or 64-bit

    Please add exactly what is written in "System Type" on the control panel.

    Also add the location of the installer and details of the installation procedure. If you have the right one installed, the installer should set the path.