Home>

The following error message is displayed when trying to bundle install a Gemfile.

An error occurred while installing sassc (2.2.0), and Bundler cannot
continue.
Make sure that `gem install sassc -v '2.2.0' --source 'https: // rubygems.org /'`
succeeds before bundling.


If gem install sassc -v '2.2.0' --source 'https://rubygems.org/' as described in the error statement

Building native extensions.This could take a while ...
Successfully installed sassc-2.2.0
Parsing documentation for sassc-2.2.0
Done installing documentation for sassc after 0 seconds
1 gem installed


In this way a message will appear as if the installation was successful. But
If i try bundle install --path vendor/bundle

Ignoring byebug-11.0.1 because its extensions are not built. Try: gem pristine byebug --version 11.0.1
Ignoring jaro_winkler-1.5.3 because its extensions are not built. Try: gem pristine jaro_winkler --version 1.5.3
Ignoring kgio-2.11.2 because its extensions are not built. Try: gem pristine kgio --version 2.11.2
Ignoring puma-3.12.1 because its extensions are not built. Try: gem pristine puma --version 3.12.1
Ignoring raindrops-0.19.0 because its extensions are not built. Try: gem pristine raindrops --version 0.19.0
Ignoring sqlite3-1.3.13 because its extensions are not built.Try: gem pristine sqlite3 --version 1.3.13
Ignoring unicorn-5.4.1 because its extensions are not built. Try: gem pristine unicorn --version 5.4.1
Fetching gem metadata from https: //rubygems.org/.........
Using rake 12.3.3
Using concurrent-ruby 1.1.5
Using i18n 1.6.0
Using minitest 5.11.3
Using thread_safe 0.3.6
Using tzinfo 1.2.5
Using activesupport 5.2.3
Using builder 3.2.3
Using erubi 1.8.0
Using mini_portile2 2.4.0
Using nokogiri 1.10.4
Using rails-dom-testing 2.0.3
Using crass 1.0.4
Using loofah 2.2.3
Using rails-html-sanitizer 1.2.0
Using actionview 5.2.3
Using rack 2.0.7
Using rack-test 1.1.0
Using actionpack 5.2.3
Using nio4r 2.5.1
Using websocket-extensions 0.1.4
Using websocket-driver 0.7.1
Using actioncable 5.2.3
Using globalid 0.4.2
Using activejob 5.2.3
Using mini_mime 1.0.2
Using mail 2.7.1
Using actionmailer 5.2.3
Using activemodel 5.2.3
Using arel 9.0.0
Using activerecord 5.2.3
Using mimemagic 0.3.3
Using marcel 0.3.3Using activestorage 5.2.3
Using public_suffix 4.0.1
Using addressable 2.7.0
Using ast 2.4.0
Using execjs 2.7.0
Using autoprefixer-rails 9.6.1.1
Using bcrypt 3.1.13
Using bindex 0.8.1
Using popper_js 1.14.5
Using method_source 0.9.2
Using thor 0.20.3
Using railties 5.2.3
Using ffi 1.11.1
Fetching sassc 2.2.0
Installing sassc 2.2.0 with native extensions
Gem :: Ext :: BuildError: ERROR: Failed to build gem native extension.
current directory:
/var/www/projects/app_name/vendor/bundle/ruby/2.6.0/gems/sassc-2.2.0/ext
/home/app_name/.rbenv/versions/2.6.4/bin/ruby -I
/home/app_name/.rbenv/versions/2.6.4/lib/ruby/2.6.0 -r
./siteconf20191123-6888-19u0fze.rb extconf.rb
creating Makefile
current directory:
/var/www/projects/app_name/vendor/bundle/ruby/2.6.0/gems/sassc-2.2.0/ext
make "DESTDIR =" clean
current directory:
/var/www/projects/app_name/vendor/bundle/ruby/2.6.0/gems/sassc-2.2.0/ext
make "DESTDIR ="
compiling ./libsass/src/prelexer.cpp
compiling ./libsass/src/base64vlq.cpp
compiling ./libsass/src/color_maps.cpp
compiling ./libsass/src/memory/SharedPtr.cpp
compiling ./libsass/src/inspect.cpp
virtual memory exhausted: Cannot allocate memory
make: *** [inspect.o] Error 1
make failed, exit code 2
Gem files will remain installed in
/var/www/projects/app_name/vendor/bundle/ruby/2.6.0/gems/sassc-2.2.0 for
inspection.
Results logged to
/var/www/projects/app_name/vendor/bundle/ruby/2.6.0/extensions/x86_64-linux/2.6.0/sassc-2.2.0/gem_make.out
An error occurred while installing sassc (2.2.0), and Bundler cannot
continue.
Make sure that `gem install sassc -v '2.2.0' --source 'https: // rubygems.org /'`
succeeds before bundling.
In Gemfile:
  bootstrap was resolved to 4.3.1, which depends on
    sassc-rails was resolved to 2.1.2, which depends on
      sassc


Also, the same error is displayed and clogged.
If i know someone, please give me a professor.

Gemfile

# frozen_string_literal: true
source 'https://rubygems.org'
# Bundle edge Rails instead: gem 'rails', github: 'rails/rails'
gem 'rails', '~>5.2.3'# Use sqlite3 as the database for Active Record
gem 'sqlite3', '~>1.3.13'
# Use Puma as the app server
gem 'puma', '~>3.0'
# Use SCSS for stylesheets
gem 'sass-rails', '~>5.0'
# Use Uglifier as compressor for JavaScript assets
gem 'uglifier', '>= 1.3.0'
# Use CoffeeScript for .coffee assets and views
gem 'coffee-rails', '~>4.2'
# See https://github.com/rails/execjs#readme for more supported runtimes
# gem 'therubyracer', platforms:: ruby
# Use jquery as the JavaScript library
gem 'jquery-rails'
# Turbolinks makes navigating your web application faster.Read more: https://github.com/turbolinks/turbolinks
gem 'turbolinks', '~>5'
# Build JSON APIs with ease.Read more: https://github.com/rails/jbuilder
gem 'jbuilder', '~>2.5'
# Use Redis adapter to run Action Cable in production
# gem 'redis', '~>3.0'
# Use ActiveModel has_secure_password
# gem 'bcrypt', '~>3.1.7'
# Use Capistrano for deployment
# gem 'capistrano-rails', group:: development
group: development,: test do
  # Call 'byebug' anywhere in the code to stop execution and get a debugger console
  gem 'byebug', platform:: mri
  # gem 'sqlite3'
end
group: development do
  # Access an IRB console on exception pages or by using<% = console%>anywhere in the code.
  gem 'listen', '~>3.0.5'
  gem 'web-console'
  # Spring speeds up development by keeping your application running in the background.Read more: https://github.com/rails/spring
  gem 'rubocop', require: false
  gem 'spring'
  gem 'spring-watcher-listen', '~>2.0.0'
end
group: production do
  # gem 'mysql2', '~>0.5.2'
  # gem 'mini_racer'
  # gem 'pg'
  gem 'unicorn', '~>5.4.1'
end
# Windows does not include zoneinfo files, so bundle the tzinfo-data gem
gem 'tzinfo-data', platforms:% i [mingw mswin x64_mingw jruby]
gem 'bootstrap', '~>4.3.1'
gem 'carrierwave'
gem 'devise'
gem 'devise-bootstrap-views'
gem 'kaminari', '~>0.17.0'
gem 'kaminari-bootstrap', '~>3.0.1'
gem 'mini_magick'
gem 'omniauth-google-oauth2'
gem 'omniauth-rails_csrf_protection'
gem 'rails-i18n'
gem 'rspec_junit_formatter'