Home>

When I was a web beginner and worked on Chapter 13 of Rails Tutorial, I installed ImageMagick with the following command.

$brew install imagemagick
Error message

After performing the above installation, when the rails server was interrupted and restarted, the following error occurred.

Traceback (most recent call last):
    23: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/bin/rails:23:in `
'     22: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/bin/rails:23:in `load '     21: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/gems/2.5.0/gems/railties-5.1.7/exe/rails:9:in `'     20: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require '     19: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require '     18: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/gems/2.5.0/gems/railties-5.1.7/lib/rails/cli.rb:16 : in `'     17: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/gems/2.5.0/gems/railties-5.1.7/lib/rails/command.rb:42 : in `invoke '     16: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/gems/2.5.0/gems/railties-5.1.7/lib/rails/command.rb:68 : in `find_by_namespace '     15: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/gems/2.5.0/gems/railties-5.1.7/lib/rails/command/behavior.rb : 77: in `lookup '     14: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/gems/2.5.0/gems/railties-5.1.7/lib/rails/command/behavior.rb : 77: in `each '     13: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/gems/2.5.0/gems/railties-5.1.7/lib/rails/command/behavior.rb : 78: in `block in lookup '     12: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/gems/2.5.0/gems/railties-5.1.7/lib/rails/command/behavior.rb : 78: in `each '     11: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/gems/2.5.0/gems/railties-5.1.7/lib/rails/command/behavior.rb : 82: in `block (2 levels) in lookup '     10: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require '      9: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require '      8: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/gems/2.5.0/gems/railties-5.1.7/lib/rails/commands/application/application_command .rb: 2: in `'      7: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require '      6: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require '      5: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/gems/2.5.0/gems/railties-5.1.7/lib/rails/generators/rails/app /app_generator.rb:1:in `'      4: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require '      3: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require '      2: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/gems/2.5.0/gems/railties-5.1.7/lib/rails/generators/app_base.rb : 2: in `'      1: from /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require ' /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require ': dlopen (/ Users/ks- live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby ​​/ 2.5.0/x86_64-darwin16/digest/md5.bundle, 9): Library not loaded:/usr/local/opt/openssl/lib /libssl.1.0.0.dylib (LoadError)   Referenced from: /Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/2.5.0/x86_64-darwin16/digest/md5.bundle   Reason: image not found-/Users/ks-live-in-tokyo/.rbenv/versions/2.5.5/lib/ruby/2.5.0/x86_64-darwin16/digest/md5.bundle


I didn't know at first, but once I uninstalled ImageMagick, it didn't seem to be relevant.
It seems that it seems that it is related to MD5, but I do not know how to deal with it.
I hope you can give me some advice.

  • Answer # 1

    Uninstalling Ruby and installing Ruby/Rails again solved it.

Related articles