Home>
I got an error trying to start the server with

rails s.

Error message
tsudashouki @ ts21 grainplatform-api% rails s
=>Booting Puma
=>Rails 5.2.3 application starting in development
=>Run `rails server -h` for more startup options
Exiting
Traceback (most recent call last):
        76: from bin/rails: 4: in `<main>'
        75: from /Users/ts/sample-api/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:291:in `require '
        74: from /Users/ts/sample-api/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:257:in `load_dependency '
        73: from /Users/tsi/sample-api/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:291:in `block in require '
        72: from /Users/tsi/sample-api/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:30:in `require '
        71: from /Users/ts/sample-api/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require_
with_bootsnap_lfi '
        70: from /Users/ts/sample-api/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in `register '
        69: from /Users/ts/sample-api/vendor/bundle/rubdle/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `block in
 require_with_bootsnap_lfi '
        68: from /Users/ts/sample-api/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `require '
        67: from /Users/ts/sample-api/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/commands.rb:18:in `<main>'
        66: from /Users/ts/sample-api/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/command.rb:46:in `invoke '
        65: from /Users/ts/sample-api/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/command/base.rb:65:in `perform '
        64: from /Users/ts/samplem-api/vendor/bundle/ruby/2.6.0/gems/thor-0.20.3/lib/thor.rb:387:in `dispatch '
        63: from /Users/ts/sample-api/vendor/bundle/ruby/2.6.0/gems/thor-
・
・
・
/Users/ts/sample-api/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/compile_cache/yaml.rb:50:in `fetch ': No such file or directory- bs_fetch: o
pen_current_file: open (Errno :: ENOENT)

I think that bootsnap is the cause of something.
Please tell me the solution.

  • Answer # 1

    Is this it? Rather than bootsnap, the cache it holds should be bad.
    For those who cannot boot Rails5.2 due to bootsnap