Home>

After replacing the PC (from Win7 to Win10), Win7 was Ruby 2.2.4 and Rails was 4.2.6.
Rails can only be installed on Ruby 2.5 or higher on a new PC, so it will work with Ruby 2.5.
I couldn't start with 4.2.6, so when I updated to 4.2.10, I got a different error and was confused.
I thought it was a problem with the version of sqlite3. I tried it a few times, but the result was the same.

Thank you.

Traceback (most recent call last):
        21: from bin/rails: 4: in `<main>'
        20: from bin/rails: 4: in `require '
        19: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/railties-4.2.10/lib/rails/commands.rb: 17: in `<top (required)>'
        18: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/railties-4.2.10/lib/rails/commands/commands_tasks.rb: 39: in `run_command! '
        17: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/railties-4.2.10/lib/rails/commands/commands_tasks.rb: 75: in `server '
        16: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/railties-4.2.10/lib/rails/commands/commands_tasks.rb: 75: in `tap '
        15: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/railties-4.2.10/lib/rails/commands/commands_tasks.rb: 78: in `block in server '
        14: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/railties-4.2.10/lib/rails/commands/commands_tasks.rb: 78: in `require '
        13: from C: /rails/middle/config/application.rb: 7: in `<top (required)>'
        12: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/bundler-1.17.3/lib/bundler.rb: 114: in `require '
        11: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/bundler-1.17.3/lib/bundler/runtime.rb: 65: in `require '
        10: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/bundler-1.17.3/lib/bundler/runtime.rb: 65: in `each '
         9: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/bundler-1.17.3/lib/bundler/runtime.rb: 76: in `block in require '
         8: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/bundler-1.17.3/lib/bundler/runtime.rb: 76: in `each '
         7: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/bundler-1.17.3/lib/bundler/runtime.rb: 81: in `block (2 levels) in require '
         6: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/bundler-1.17.3/lib/bundler/runtime.rb: 81: in `require '
         5: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/sqlite3-1.3.13-x64-mingw32/lib/sqlite3.rb: 2: in `<top (required)>'
         4: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/sqlite3-1.3.13-x64-mingw32/lib/sqlite3.rb: 6: in `rescue in<top (required)>'
         3: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/activesupport-4.2.10/lib/active_support/dependencies.rb: 274: in `require '
         2: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/activesupport-4.2.10/lib/active_support/dependencies.rb: 240: in `load_dependency '
         1: from C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/activesupport-4.2.10/lib/active_support/dependencies.rb: 274: in `block in require '
C: /Ruby25-x64/lib/ruby/gems/2.5.0/gems/activesupport-4.2.10/lib/active_support/dependencies.rb: 274: in `require ': cannot load such file-sqlite3/sqlite3_native ( LoadError)