Home>
Even if I hit ip in the browser, nginx is not displayed and I am in trouble.

centos7
nginx -v nginx version: nginx/1.11

firewall settings

sudo vi /etc/firewalld/services/ssh.xml
<? xml version = "0.0" encoding = "utf-8"?>
<service>
  <short>SSH</short>
  <description>Secure Shell (SSH) is a protocol for logging into and executing commands on remote machines.It provides secure encrypted communications.If i plan on accessing your machine remotely via SSH over a firewalled interface, enable this option.You need the openssh -server package installed for this option to be useful.</description>
  <port protocol = "tcp" port = "12345" />
</service>


Executed below

sudo firewall-cmd --reload
sudo systemctl restart sshd.service
public (active)
  target: default
  icmp-block-inversion: no
  interfaces: eth0
  sources:
  services: dhcpv6-client http ssh
  ports: 12345/tcp
  protocols:
  masquerade: no
  forward-ports:
  source-ports:
  icmp-blocks:
  rich rules:


We are also implementing:

The status is normal.

systemctl status nginx
* nginx.service-The nginx HTTP and reverse proxy server
   Loaded: loaded (/usr/lib/systemd/system/nginx.service;enabled;vendor preset: disabled)
   Active: active (running) since Thu 2019-10-10 14:14:08 JST;2h 29min ago
 Main PID: 24412 (nginx)
   CGroup: /system.slice/nginx.service
           | -24412 nginx: master process/usr/sbin/nginx
           `-24413 nginx: worker process
firewall-cmd --zone = public --add-port = 12345/tcp --permanent
sudo firewall-cmd --add-service = http --permanent
sudo firewall-cmd --reload
Error

The response time is too long even if you type ip160.160.160.160 on the browser.