Home>

I'm sorry for being late at night.

I'm trying to install

ActivityWatch, such as ManicTime, but when I run themake buildcommand, it says "73 vulnerabilities were found" in English It was.

AndWARNING Compiled with 14 warningscame out on the way.
One example will be extracted and I will ask you a question.
How can I resolve the error below the bash command result arrow (# ↓↓↓↓↓↓↓↓) below?

Thanks for your patience.

(omitted)
added 2294 packages from 1206 contributors and audited 949135 packages in 64.607s
found 73 vulnerabilities (63 low, 2 moderate, 6 high, 2 critical)
  run `npm audit fix` to fix them, or` npm audit` for details
npm run build
>[email protected] build/home/yusuke/activitywatch/aw-server/aw-webui
>vue-cli-service build

⠙ Building for production ... Starting type checking service ...
Using 1 worker with 2048MB memory limit
⠧ Building for production ...
 WARNING Compiled with 14 warnings 12:01:18 AM
# ↓↓↓↓↓↓↓↓
Module Warning (from ./node_modules/eslint-loader/index.js):
error: 'drawLegend' was used before it was defined (@ typescript-eslint/no-use-before-define) at src/visualizations/sunburst-clock.js: 52: 3:
  50 | .attr ('transform', 'translate (' + width/2 + ',' + height/2 + ')');
  51 |
>52 | drawLegend (el);
     | ^
  53 |
  54 | partition = d3.partition (). Size ([2 * Math.PI, radius * radius]);
  55 |

ActivityWatch installation official documentation

stack overflow .

  • Answer # 1

    google translation
    "DrawLegend" was used before being defined

Related articles

Trends