Home>
Introduction

I am a development beginner who releases an app for the first time.
I am in trouble when I try to Validate the created application by Product → Archive.

error contents


App Store Connect Operation Error
Missing required icon file.The bundle does not contain an app icon for iPhone/iPod Touch of exactly '120x120' pixels, in .png format for iOS versions >= 10.0. To support older versions of iOS, the icon may be required in the Make outside the an asset catalog.Make sure the Info.plist file includes appropriate entries referencing the file.See https://developer.apple.com/documentation/bundleresources/information_property_list/user_interface


App Store Connect Operation Error
Missing required icon file.The bundle does not contain an app icon for iPad of exactly '167x167' pixels, in .png format for iOS versions supporting iPad Pro. To support older operating systems, the icon may be required in the bundle outside of an asset catalog. Make sure the Info.plist file includes appropriate entries referencing the file.See https://developer.apple.com/documentation/bundleresources/information_property_list/user_interface


App Store Connect Operation Error
Missing required icon file.The bundle does not contain an app icon for iPad of exactly '152x152' pixels, in .png format for iOS versions >= 10.0. To support older operating systems, the icon may be required in the bundle outside of an asset catalog. Make sure the Info.plist file includes appropriate entries referencing the file.See https://developer.apple.com/documentation/bundleresources/information_property_list/user_interface

Awareness of what you did and errors

If i read it literally, I interpreted that it was said that it should be added because there are not enough icons of 120 × 120, 167 × 167, 152 × 152. And I also understood that it is necessary to correspond to versions before ios 10.0, so I added an image of a size that is said to be insufficient for the project itself, made icon files with info.plist, and created each image file name. Set. (Although the image is already included in the asset, I felt strange.)

We have also confirmed the size of each image in the asset and that the images are not transparent.
We also confirmed that Target Membership is checked.

I can understand if there are errors in all images, but I'm not sure why there are errors in some images.

To be honest, it's pretty clumsy, so I would appreciate it if anyone could give me some advice.