Home>

Before I knew it, rails -v in the application in question

Your Ruby version is 2.6.3, but your Gemfile specified 2.6.2


Came out. ..
Once I thought that the switch was successful, I restarted the terminal and the same error was thrown, and I could not change it from there.

The sites I referred to are the following.
https://qiita.com/ryu1_f/items/ee308dd1c11faf6f3eb0

$which bundler
/Users/hoge/.rbenv/shims/bundler
*Hoge = my username
$which ruby
/Users/hoge/.rbenv/shims/ruby
$rbenv versions
* 2.6.2 (set by /Users/hoge/rails/rails-community/.ruby-version)

If i try to deploy on Heroku due to the influence of this area,

###### WARNING:
       There is a known bundler bug with your version of Ruby
       Your version of Ruby contains a problem with the built-in integration of bundler.If
       you encounter a bundler error you need to upgrade your Ruby version. We suggest you upgrade to:
       2.6.6
       For more information see:
         https://devcenter.heroku.com/articles/bundler-version#known-upgrade-issues


I get an error like
*It is speculated whether this is the cause;

Also, the error that is being vomited by Heroku? There are some things that I don't really understand, and I am not sure what to fix.
The full error of Heroku will be the following URL. (Is it possible to view it from the URL below...? Write the error point as if it could not be done.)
▼ Build Log
https://dashboard.heroku.com/apps/rails-community-ym/activity/builds/fef88eb0-9895-46e3-8b10-f8a5ed18ced0

An error-like part of Heroku
###### WARNING:
       There is a known bundler bug with your version of Ruby
       Your version of Ruby contains a problem with the built-in integration of bundler.If
       you encounter a bundler error you need to upgrade your Ruby version. We suggest you upgrade to:
       2.6.6
       For more information see:
         https://devcenter.heroku.com/articles/bundler-version#known-upgrade-issues
----->install dependencies using bundler 1.17.3
       Run: bundle install --without development: test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment
       The dependency tzinfo-data (>=0) is not used by the platform that Bundler has installed. Bundler is installed for ruby, but the dependencies are only x86-mingw32, x86-mswin32, x64-mingw32, java. To add these platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`.
HEADS UP! i18n 1.1 changed fallbacks to exclude default locale.
       But that may break your application.
       If i am upgrading your Rails application from an older version of Rails:
       Please check your Rails app for'config.i18n.fallbacks = true'.
       If you're using I18n (>= 1.1.0) and Rails (<5.2.2), this should be
       'config.i18n.fallbacks = [I18n.default_locale]'.
       If not, fallbacks will be broken in your app by I18n 1.1.x.
        If i am starting a NEW Rails application, you can ignore this notice.For more info see:
       https://github.com/svenfuchs/i18n/releases/tag/v1.1.0
----->Detecting rake tasks
 !!
 ! Could not detect rake tasks
 ! ensure you can run `$bundle exec rake -P` against your app
 ! and using the production group of your Gemfile.
 !rake aborted!
NameError: undefined local variable or method `config' for main:Object


When you execute ↑

rake aborted!


Will be. Again, I tried various things so that the command could pass, but
When I closed the terminal, I couldn't get through again;

And at the very end

!! The push was rejected and the Ruby app couldn't be compiled.
!! Push failed


Error is thrown and I cannot deploy;

I spent a whole day yesterday researching and trying, but it's hard to move forward;
I'm confused as to where to start, so I'd appreciate it if someone could tell me.

  • Answer # 1

    The reason was that I was using @import in the css file, not the error during deployment.
    After changing from apllication.css to apllication.scss and deploying, it passed safely.
    We are sorry for the inconvenience to those who saw the error.