Home>

I am setting up WordPress on xrea.com.
The xrea plan is set as a free plan.

Both the WordPress management screen site and the reflection site are "unprotected communication".
Applicable source code
Since it is a setting, there is no source code.
What I tried

I tried SSL setting and htaccess setting, but if I set https, it will be the Forbidden 401 page. (The WordPress login page will also not be displayed.)

I also tried the plugins (Really Simple SSl, Redirection, Search Regex, SSL Insecure Content Fixer, WP Force SSL) but it didn't work.
Some of the plugin settings instructed me to change the WordPress address and the address again to https, and after doing it, Forbidden 401 will be displayed, so enter MyAdmin and set the siteurl and home contents of wp_options to http I am checking again after re-entering the management screen of WordPress.

Supplemental information (FW/tool ​​version, etc.: set by default version)

We apologize for the inconvenience, but we would appreciate it if you could give us a solution.

  • Answer # 1

    After various investigations, it seems that free SSL cannot be set if the site is created.
    I will write down the procedure that I found out below and give it a try.

    ① Change the main domain from the original domain to the default domain.
    ⇒ (account name).xrea.com

    ② Click New Site Settings and create with the following settings
    ⇒ Domain name: Select your own domain
    ⇒ SSL: Select free SSL

    ③ Move the contents of putblic_html to public_html/ (own domain) because the route is changed

    The above steps seem to work.