Home>

I would like to be able to operate a desktop Windows PC remotely.
Initially, I wanted to use Wake On Lan (WoL), which comes standard with TeamViewer.
I couldn't start it no matter how many times I tried, so when I was looking for the cause, I was asked if I needed to release the port.
I currently live in an apartment and have a router from the beginning, so I searched for a Wake On Lan method that can be done without opening the port.

So https://qiita.com/tomp/items/2c27ff4d6efc1a459bd1 I referred to this article.

After performing all the steps, I started by typing a command to the terminal several times and started from the shell file successfully, but when I rebooted the Raspberry Pi, I could not start both the terminal and shell file.
It may start occasionally when all the processes are performed again, but it can hardly be started.

The PC to be started has a fixed IP address and is connected to the router by wire.

Since I bought the Raspberry Pi for the first time for WoL, I am an amateur of Raspberry Pi.
I haven't touched the settings of the PC to be booted, so I wonder if any settings have changed when I rebooted the Raspberry Pi.

What I tried

The above article uses python, but for some reason it didn't succeed, so I used python3 and it succeeded.
So since then, both terminal and shell files are running on python3.
I've been successful several times, so I don't think there's a problem with the article or the code itself. (I think [cd Wake-On-Lan-Python] is correct for [cd wol-python] in the shell file at the end of the article)

Supplementary information (FW/tool version, etc.)

PC to boot: Windows 10 Pro
RaspberryPi: RaspberryPi zero w

  • Answer # 1

    From the exchange in the comment of the question, the connection is as follows,
    ・ Wi-Fi with built-in Raspberry Pi → Router in the wall (W-iFi and wired LAN can be used through this) → PC to be started
    It means that the router in the wall is a black box.

    Since the specifications of the router inside the wall are unknown, the following explanation is largely speculative.

    Is it clearly stated in the manual that communication can be performed between Wi-Fi and wired LAN? (Or have you ever received such an explanation from someone familiar with the technology?)
    If that isn't certain, it may just happen that we were able to communicate, and it may not be possible.

    It may be more reliable to attach a USB-connected wired LAN to the Raspberry Pi and make it only a wired LAN connection. (However, additional equipment is required, and even if you make an additional investment, we do not guarantee that this will solve the problem.)
    If this doesn't work, you can narrow down the problem to the Raspberry Pi side instead of the router.

    If you want to investigate further in the existing network environment, use the "ifconfig -a" or "ip a" command on Raspai to investigate whether the WOL works or not, and whether there is a rule in the network settings. That is. (I suspect that there may be a difference in the address band of the IP address issued by the router in each case.)

  • Answer # 2

    If you want to boot your PC with WOL, you need to enable WOL in the BIOS, is that set up properly?