Home>

Windows 10
Ruby 2.7.2
rails 5.2.2.4

With the introduction of Bootstrap, I stumbled and couldn't even display the page.

When I accessed the top page

RuntimeError in Home # top
Your ExecJS runtime Duktape isn't supported by autoprefixer-rails,
please switch to Node.js (V8) or mini_racer (V8)

Was displayed.

When I checked the version of Node.js, it was v12.19.0.
mini_racer tried to install but got an error

An error occurred while installing libv8 (8.4.255.0), and Bundler cannot
continue.
Make sure thatgem install libv8 -v '8.4.255.0' --source 'https://rubygems.org/'succeeds before bundling.
In Gemfile:
mini_racer was resolved to 0.3.1, which depends on
libv8

I can't install libv8 because it's stuck.

gem'libv8','~>8.4','>= 8.4.255.0'
gem'mini_racer','~>0.3.1'


I would appreciate it if you could teach me the solution.

  • Answer # 1

    It was solved by reintroducing Bootstrap.
    Perhaps I was messing around with something strange without realizing it.

    It was OK to install bootstrap-sass and import with a new scss file.

Related articles

Trends