Home>
I want to achieve: Update the centos8 package

An error occurs even if I execute the following.

The errors that are occurring are as follows.

$sudo dnf update
Final confirmation of metadata expiration: 2:54:22 Hours ago, November 17, 2020, 13:45:30.
Error:
 Problem 1: cannot install the best update candidate for package libidn2-2.2.0-1.el8.x86_64
  --nothing provides libunistring.so.0 () (64bit) needed by libidn2-2.3.0-1.el6.x86_64
 Problem 2: cannot install the best update candidate for package libstoragemgmt-1.8.3-1.el8.x86_64
  --nothing provides libudev.so.0 () (64bit) needed by libstoragemgmt-1.8.4-1.el6.x86_64
  --nothing provides libconfig.so.8 () (64bit) needed by libstoragemgmt-1.8.4-1.el6.x86_64
(Try adding'--skip-broken' or'--nobest' to skip non-installable packages and don't use only the best candidate packages)


Previously, in order to compile OpenCV, I had to install the necessary dependencies on my system, so I was getting this error when I ran the following:

$dnf install epel-release make git gcc gcc-c ++ cmake3 qt5-qtbase-devel python3 python3-devel python3-pip cmake python3-devel python3-numpy gtk2-devel libpng-devel libwebp-devel libjpeg-turbo-devel libtiff-devel tbb -devel freeglut-devel mesa-libGL mesa-libGL-devel boost boost-thread boost-devel gstreamer1-plugins-base -y
Error:
 Problem: package cmake3-3.6.1-3.el6.x86_64 requires libarchive.so.14 () (64bit)
, but none of the providers can be installed
  --conflicting requests
  --nothing provides liblzma.so.0 () (64bit) needed by libarchive3-3.3.1-1.el6.x86_64
(To skip non-installable packages, try adding'--skip-broken' or add'--nobest' and don't use only the best candidate packages)

I searched from the error text, but couldn't find any literature to solve it.

Thanks for your support.