Home>
Example of what I want to achieve

I am trying to use the L3 switch as a pseudo-opposite that imitates a server device with multiple I/Fs and IPs.
For IP, I think it is only necessary to be able to ping.

Gi1/1: 192.168.0.1/24 (routed port)
Gi1/2: 192.168.0.2/24 (routed port)
Gi1/3: vlan 100 (switching port)
Gi1/4: vlan 100 (switching port)
vlan 100: SVI is 192.168.0.100/24, and if either Gi1/3 or Gi1/4 is linked up, please fix it to one port and respond.
Excerpt from the config that tried to realize ↑
ip vrf VRF_RoutedPort11
rd 1: 1
ip vrf VRF_RoutedPort12
rd 1: 2
ip vrf VRF_SVI_100
rd 1: 100
interface gigabitEthernet 1/1
 ip vrf forwarding VRF_RoutedPort11
 no switchport
 ip address 192.168.0.1 255.255.255.0
 no shutdown
interface gigabitEthernet 1/2
 ip vrf forwarding VRF_RoutedPort12
 no switchport
 ip address 192.168.0.2 255.255.255.0
 no shutdown
interface gigabitEthernet 1/3
 switchport
 switchport mode access
 switchport access vlan 100
 no shutdown
interface gigabitEthernet 1/4
 switchport
 switchport mode access
 switchport access vlan 100
 no shutdown
interface vlan 100
 ip vrf forwarding VRF_SVI_100
 ip address 192.168.0.100 255.255.255.0
 no shutdown
The problem i am having

The I/F that input the routed port/SVI setting is from the MAC address that the I/F originally has.
It will be rewritten to one MAC address.

Before applying routed port

Gi1/1: xxxx.yyyy.0001
Gi1/2: xxxx.yyyy.0002
Gi1/3: xxxx.yyyy.0003
Gi1/4: xxxx.yyyy.0004


After applying the routed port

Gi1/1: xxxx.yyyy.a010
Gi1/2: xxxx.yyyy.a010
Gi1/3: xxxx.yyyy.a010
Gi1/4: xxxx.yyyy.a010
I want to answer
  1. I want to know why the MAC address is overwritten when applying a routed port to the I/F on the L3 switch.
  2. I would like to know if there is a way to prevent the MAC address from being overwritten even if the routed port is applied.
  3. I would like to know if there is a way to change the MAC address to some extent apart from applying the routed port.
Supplementary information

I tried it on two units, Catalyst and Nexus, but it is the same that they overlap.
I think that it is not a device alone but a reason for specifications.
I confirmed that there is a command to specify the MAC address from the I/F on Nexus7000,
The Catalyst 4948 and Nexus 3000 used this time did not have a similar command.

  • Answer # 1

    https://www.cisco.com/c/ja_jp/support/docs/switches/catalyst-6000-series-switches/41263-catmac-41263.pdf
    It was explained at the above URL.

    I want to know why the MAC address is overwritten when applying a routed port to the I/F on the L3 switch.
    → The L3 interface (routed port) and SVI all have the same MAC address.
    Due to the internal structure, each VLAN has a separate MAC address table, so there is no effect on operation.

    I would like to know if there is a way to prevent the MAC address from being overwritten even if the routed port is applied.
    → It doesn't seem to be.

    I would like to know if there is a way to change the MAC address to some extent apart from applying the routed port.
    → Some models can be changed manually depending on the switch model.
    Some chassis-type switches are supported, not fixed-configuration switches.