Home>

Using the command prompt on win10
I can't install scikit-learn.
The following error message has appeared, so please tell me how to deal with it.

C: \ Users \ ken>pip install scikit-learn
Collecting scikit-learn
  Using cached scikit_learn-0.23.2-cp38-cp38-win_amd64.whl (6.8 MB)
Requirement already satisfied: numpy>= 1.13.3 in c: \ users \ ken \ appdata \ local \ packages \ pythonsoftwarefoundation.python.3.8_qbz5n2kfra8p0 \ localcache \ local-packages \ python38 \ site-packages (from scikit-learn) (1.19) .Four)
Requirement already satisfied: threadpoolctl>= 2.0.0 in c: \ users \ ken \ appdata \ local \ packages \ pythonsoftwarefoundation.python.3.8_qbz5n2kfra8p0 \ localcache \ local-packages \ python38 \ site-packages (from scikit-learn) (2.1 .0)
Requirement already satisfied: joblib>= 0.11 in c: \ users \ ken \ appdata \ local \ packages \ pythonsoftwarefoundation.python.3.8_qbz5n2kfra8p0 \ localcache \ local-packages \ python38 \ site-packages (from scikit-learn) (0.17.0) )
Requirement already satisfied: scipy>= 0.19.1 in c: \ users \ ken \ appdata \ local \ packages \ pythonsoftwarefoundation.python.3.8_qbz5n2kfra8p0 \ localcache \ local-packages \ python38 \ site-packages (from scikit-learn) (1.5 .Four)
Installing collected packages: scikit-learn
ERROR: Could not install packages due to an EnvironmentError: [Errno 2] No such file or directory:'C: \\ Users \\ ken \\ AppData \\ Local \\ Packages \\ PythonSoftwareFoundation.Python.3.8_qbz5n2kfra8p0 \\ LocalCache \\ local-packages \\ Python38 \\ site-packages \\ sklearn \\ datasets \\ tests \\ data \\ openml \\ 292 \\ api-v1-json-data-list-data_name-australian-limit-2 -data_version-1-status-deactivated.json.gz'
WARNING: You are using pip version 20.2.1;however, version 20.2.4 is available.
You should consider upgrading via the'C: \ Users \ ken \ AppData \ Local \ Microsoft \ WindowsApps \ PythonSoftwareFoundation.Python.3.8_qbz5n2kfra8p0 \ python.exe -m pip install --upgrade pip' command.
language
Python
Supplementary information (FW/tool version, etc.)

win10
Python 3.8.3

Please provide more detailed information here.