Home>

Hello.


HereI would like to install the library of.
Get turbo-jpeg and ffmpeg (dev) according to the README,setup.pyI am rewriting the path of to suit my environment.
Installationpython -m pip install -e ..When you execute, a large number of errors are output as shown below.

Error statement
The error statement is because I was caught in the character limitHereI am uploading to.
(15:10 postscript) It is the result of installing MinGW and trying it.Here
(11/21 postscript) This is the result of installing turbo-jpeg (VC64) and changing to the VisualStudio C ++ compiler.Here

Be in trouble
The same error is output no matter how many times I work with a new environment.
Running Anaconda Prompt with administrator privileges gave the same result.
There was also a notation of the C ++? Compiler in Visual Studio 2017, so I tried reinstalling it, but the result did not change.
I'm almost new to python.
If anyone can understand the cause, I would appreciate it if you could teach me.

How to install turbo-jpeg (additional note)
・Here (turbo-jpeg)Fromlibjpeg-turbo-2.0.6-gcc.exeDL
-Create a work folder directly under the C drive to match the folder structure of setup.py just in case.
libjpeg-turbo-2.0.6-gcc.exeLaunch and install in C: \ work \
C: \ work \ libjpeg-turbo-gccBecause it became a configurationsetup.pyTotj_dir = "C: \\ work \\ libjpeg-turbo-gcc"Fixed to

environment
OS: Windows10 Pro (1909)
python: ver.3.8 (miniconda3 virtual environment)

  • Answer # 1

    I will answer as far as I can understand.

    Ignore the unknown option'-std = c ++ 11'.


    The above warning does not seem to be a problem.
    Visual Studio's C ++ 11 support is turned on by default, so it doesn't seem to make sense to specify it.
    Reference) https://stackoverrun.com/ja/q/8102457

    If you use GCC other than Visual Studio, there may be other solutions.