Home>

I'm learning while looking at a book called python first grade on a Mac.
I get an error like this when I try to get the PIL in the terminal

input:
pip3 install pillow

result:
Requirement already satisfied: pillow in ./Library/Python/3.9/lib/python/site-packages (8.0.1)
WARNING: You are using pip version 20.2.3;however, version 20.2.4 is available.
You should consider upgrading via the'/Library/Frameworks/Python.framework/Versions/3.9/bin/python3.9 -m pip install --upgrade pip' command.

If anyone knows the solution, please help me ...

  • Answer # 1

    Requirement already satisfied: pillow in ./Library/Python/3.9/lib/python/site-packages (8.0.1)

    Is as you saw.

    You are using pip version 20.2.3;however, version 20.2.4 is available.

    As you saw,pipThere is a new version of, so why not update it? Is to say.
    As written,/Library/Frameworks/Python.framework/Versions/3.9/bin/python3.9 -m pip install --upgrade pipUpdate with the command.

  • Answer # 2

    Thank you