Home>

I'm a MAC user
I'm sorry to ask you many questions
When I type pip3 install scikit-learn in the terminal, I get an error like this after a while

Result: Collecting scikit-learn
Using cached scikit-learn-0.23.2.tar.gz (7.2 MB)
Installing build dependencies ... error
ERROR: Command errored out with exit status 1:
command: /Library/Frameworks/Python.framework/Versions/3.9/bin/python3.9 /Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/pip install --ignore-installed --no-user --prefix/private/var/folders/w0/38w6bwls0kn978d9prgwj0bc0000gr/T/pip-build-env-z95ijr81/overlay --no-warn-script-location --no-binary: none: --only -binary: none: -i https://pypi.org/simple --setuptools wheel'Cython>= 0.28.5''numpy == 1.13.3;python_version =='"'"'3.6'"'"' and platform_system! ='"'"'AIX'"'"' and platform_python_implementation =='"'"'CPython'"'"'''numpy == 1.14.0;python_version =='"'"'3.6'" '"' and platform_system! ='"'"'AIX'"'"' and platform_python_implementation! ='"'"' CPython'"'"''' numpy == 1.14.5;python_version =='"'"' 3.7'"'"' and platform_system! ='"'"'AIX'"'"'''numpy == 1.17.3;python_version>='"'"' 3.8'"'"' and platform_system! ='" '"' AIX'"'"''' numpy == 1.16.0;python_version =='"'"' 3.6'"'"' and platform_system =='"'"' AIX'"'"''' numpy == 1.16.0;python_version =='"'"'3.7'"'"' and platform_ system =='"'"'AIX'"'"'''numpy == 1.17.3;python_version>='"'"'3.8'"'"' and platform_system =='"'"'AIX'"' "'''scipy>= 0.19.1'

etc,,,

If anyone knows the solution, thank you.