Home>

When I try to deploy on AWS

Autoprefixer does n’t support Node v6.17.1. Update it.


Error occurs
It looks like an error telling me to update Node.js
My version is

node -v
v15.2.1


Is not v6.17.1

Leave it for the time beingHereI tried to deal with it
At the time of the first deletion

sudo: yum: command not found


Can't solve the problem and can't move forward

Even if I search, the solution is just like the above method and I am in trouble

Professor please

Postscript

deploy.rb

# config valid only for current version of Capistrano
Described the version of #capistrano. Continue to use the fixed version and prevent troubles due to version change
lock '3.14.1'
Used to display # Capistrano logs
set: application,'baseball-app'
# Specify from which repository I want to pull your app
set: repo_url,'[email protected]: katou02/baseball-app.git'
#Specify a directory to be referenced in common even if the version changes
set: linked_dirs, fetch (: linked_dirs, []). push ('log','tmp/pids','tmp/cache','tmp/sockets','vendor/bundle','public/system',' public/uploads')
set: rbenv_type,: user
set: rbenv_ruby, '2.5.1'
#Which public key to use for deployment
set: ssh_options, auth_methods: ['publickey'],
                  keys: ['~/.ssh/rails-baseball.pem']
#Location of the file containing the process number
set: unicorn_pid,->{"# {shared_path} /tmp/pids/unicorn.pid"}
# Unicorn configuration file location
set: unicorn_config_path,->{"# {current_path} /config/unicorn.rb"}
set: keep_releases, 5
# Description for restarting Unicorn after the deployment process is finished
after'deploy: publishing','deploy: restart'
namespace: deploy do
  task: restart do
    invoke'unicorn: restart'
  end
end

Capfile

require "capistrano/setup"
require "capistrano/deploy"
require'capistrano/rbenv'
require'capistrano/bundler'
require'capistrano/rails/assets'
require'capistrano/rails/migrations'
require'capistrano3/unicorn'
Dir.glob ("lib/capistrano/tasks/*. rake"). each {| r | import r}
nodejs -v
-bash: nodejs: command not found

Multi
Here