Home>

I'm developing a web application with Rails, but I can't access it when I start the server

pi @ raspberrypi: ~/environment/hello_app $rails server -b 0.0.0.0
=>Booting Puma
=>Rails 6.0.3 application starting in development
=>Run `rails server --help` for more startup options
Puma starting in single mode ...
* Version 4.3.6 (ruby 2.6.3-p62), codename: Mysterious Traveler
* Min threads: 5, max threads: 5
* Environment: development
* Listening on tcp: //0.0.0.0:3000
Use Ctrl-C to stop


The server can be started, but when I try to access it from a web browser

Is displayed and cannot be accessed
Of course, I also edited the config/environments/development.rb file and it looks like this:

Rails.application.configure do
  # Settings specified here will take precedence over those in config/application.rb.
  # In the development environment your application's code is reloaded on
  # every request. This slows down response time but is perfect for development
  #since you don't have to restart the web server when you make code changes.
  config.cache_classes = false
  # Do not eager load code on boot.
  config.eager_load = false
  # Show full error reports.
  config.consider_all_requests_local = true
  # Enable/disable caching. By default caching is disabled.
  #Run rails dev: cache to toggle caching.
  if Rails.root.join ('tmp','caching-dev.txt'). Exist?
    config.action_controller.perform_caching = true
    config.action_controller.enable_fragment_cache_logging = true
    config.cache_store =: memory_store
    config.public_file_server.headers = {
      'Cache-Control' =>"public, max-age = # {2.days.to_i}"}
  else else
    config.action_controller.perform_caching = false
    config.cache_store =: null_store
  end
  #Store uploaded files on the local file system (see config/storage.yml for options).
  config.active_storage.service =: local
  # Don't care if the mailer can't send.
  config.action_mailer.raise_delivery_errors = false
  config.action_mailer.perform_caching = false
  # Print deprecation notices to the Rails logger.
  config.active_support.deprecation =: log
  # Raise an error on page load if there are pending migrations.
  config.active_record.migration_error =: page_load
  #Highlight code that triggered database queries in logs.
  config.active_record.verbose_query_logs = true
  # Debug mode disables concatenation and preprocessing of assets.
  # This option may cause significant delays in view rendering with a large
  # number of complex assets.
  config.assets.debug = true
  #Suppress logger output for asset requests.
  config.assets.quiet = true
  #Raises error for missing translations.
  # config.action_view.raise_on_missing_translations = true
  # Use an evented file watcher to asynchronously detect changes in source code,
  #routes, locales, etc. This feature depends on the listen gem.
  config.file_watcher = ActiveSupport :: EventedFileUpdateChecker
  config.hosts.clear Allow access to # Cloud9
end
What I tried
  • Firewall check (not installed)
  • I used ping for 0.0.0.0 and checked if the response came back (ping came back)
  • Reboot because the settings may not have been loaded (still the situation remains ...)
  • I tried to access localhost without specifying the port, but the connection was refused
Supplementary information (FW/tool version, etc.)

Follow the Rails tutorial

Ruby version 2.6.3
Rails version 6.0.3
Browser brave
The Rails tutorial is the first chapter of Rails 6.0 (6th edition)

I don't know if it will be helpful, but I will keep the contents of the Gemfile

source'https://rubygems.org'
git_source (: github) {| repo | "https://github.com/#{repo}.git"}
gem'rails', '6.0.3'
gem'puma', '4.3.6'
gem'sass-rails', '5.1.0'
gem'webpacker', '4.0.7'
gem'turbolinks', '5.2.0'
gem'jbuilder', '2.9.1'
gem'bootsnap', '1.4.5', require: false
group: development,: test do
  gem'sqlite3', '1.4.1'
  gem'byebug', '11 .0.1', platforms: [: mri,: mingw,: x64_mingw]
end
group: development do
  gem'web-console', '4.0.1'
  gem'listen', '3.1.5'
  gem'spring', '2.1.0'
  gem'spring-watcher-listen', '2.0.1'
end
group: test do
  gem'capybara', '3.28.0'
  gem'selenium-webdriver', '3.142.4'
  gem'webdrivers', '4.1.2'
end
# On Windows you need to include a tzinfo-data gem for timezone information
gem'tzinfo-data', platforms: [: mingw,: mswin,: x64_mingw,: jruby]

I will wait for your reply