Home>

I'm trying to develop Android with Visual Studio. However, when I installed the emulator and tried to debug it, "A placement error occurred. "Do I want to continue?" Is displayed and debugging is not possible.

There are two errors below.

ADB0010: Deployment failed
Mono.AndroidTools.InstallFailedException: Failure [INSTALL_FAILED_MISSING_SHARED_LIBRARY: Package couldn't be installed in /data/app/Schedule1.Schedule1-2n-VvhKUuD0Ta3U6HWNhFw ==: Package Schedule1.Schedule1
ADB0010: Mono.AndroidTools.InstallFailedException: Failure [INSTALL_FAILED_MISSING_SHARED_LIBRARY: Package couldn't be installed in /data/app/Schedule1.Schedule1-2n-VvhKUuD0Ta3U6HWNhFw ==: Package Schedule1.Schedule1 requires unavailable shared library com.google.and failing!]

Apparently, I'm told that I'm missing some packages, but I don't know what I installed and how.

What went

  • HereI made "adb install -r Schedule1.Schedule1.apk" at the Android ADB command prompt referring to. Then, "Performing Push Install adb: error: failed to get feature set: no devices/emulators found" was displayed.
    I checked it with this, but only the method of debugging the actual machine comes out. If it can be done on the actual device, that may be fine, but I want to use an emulator because I want to check if there is any display corruption on various terminals. (I got a placement error even when I tried it on the actual machine.)
  • I typed "adb devices" at the Android ADB command prompt. Then, only "List of devices attached" came out.
  • I reset the emulator and restored it to factory default.
  • I downloaded platform-tools and set the location of adb.exe to an environment variable.
  • I installed the Google USB driver from the Android SDK manager.

The emulator is Pixel 2 Pie 9.0 and the target framework is Android 9.0 (Pie).
How can I debug using an emulator?