Home>

I currently want to use it with anaconda3 with python version 3.7.0.

When installing anaconda3, I checked the top of the image below and unchecked the bottom part. (It is 3.7 in the image, but it is 3.8 now.)


After that, I was able to install anaconda3 safely, but at the command prompt

conda install python == 3.7.0


When you run

PackageNotFounedError: Package missing in current win-64 channels: -python == 3.7.0


Error statement is displayed.
With Anaconda Prompt

pip install python == 3.7.0


When you run

ERROR: Could not find a version that satisfies the requirement python == 3.7.0 (from versions none)
ERROR: No matching distribution found for python == 3.7.0


Error statement is displayed.

From the error statement, it is probably difficult to install python3.7.0 now, but is there a way to install python3.7.0?
Also, are there any changes in the latest versions of python 3.8.0 and 3.7.0?
We look forward to hearing from you.

  • Answer # 1

    An error occurred because the free space on the PC was low.
    After increasing the free space from 2㎇ to 30㎇, the download was successful.
    Thank you to everyone who answered.

  • Answer # 2

    How about creating a virtual environment for Python 3.7?

    conda create -n py37 python == 3.7

    * Py37 is an example. Please use any name you like.