Home>

I'm trying to install and launch MySQL, but I've been fighting the error for three days
Will not solve. . Please lend me your wisdom. .

[root @ localhost log] # /etc/init.d/mysqld start
/ usr/bin/mysqld_safe: line 935: kill: (6804)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (6893)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (6977)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (7076)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (7388)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (7388)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (7388)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (7388)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (7596)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (7701)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (8135)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (8135)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (8135)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (8135)-no permission
/ usr/bin/mysqld_safe: line 935: kill: (8343)-no permission
MySQL Daemon failed to start.
Starting mysqld: [failed]
[root @ localhost log] # mysqld
2017-03-05 22:26:09 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated.Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2017-03-05 22:26:09 0 [Note] mysqld (mysqld 5.6.35) starting as process 29910 ...
2017-03-05 22:26:09 29910 [ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!
2017-03-05 22:26:09 29910 [ERROR] Aborting
2017-03-05 22:26:09 29910 [Note] Binlog end
2017-03-05 22:26:09 29910 [Note] mysqld: Shutdown complete
[root @ localhost log] # cat /etc/my.cnf
# For advice on how to change settings please see
# http://dev.mysql.com/doc/refman/5.6/en/server-configuration-defaults.html
[mysqld]
#
# Remove leading # and set to the amount of RAM for the most important data
# cache in MySQL.Start at 70% of total RAM for dedicated server, else 10%.
# innodb_buffer_pool_size = 128M
#
# Remove leading # to turn on a very important data integrity option: logging
# changes to the binary log between backups.
# log_bin
#
# Remove leading # to set options mainly useful for reporting servers.
# The server defaults are faster for transactions and fast SELECTs.
# Adjust sizes as needed, experiment to find the optimal values.
# join_buffer_size = 128M
# sort_buffer_size = 2M
# read_rnd_buffer_size = 2M
datadir =/var/lib/mysql
socket =/var/lib/mysql/mysql.sock
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links = 0
# Recommended in standard MySQL setup
sql_mode = NO_ENGINE_SUBSTITUTION, STRICT_TRANS_TABLES
[mysqld_safe]
log-error =/var/log/mysqld.log
pid-file =/var/run/mysqld/mysqld.pid

[client]
default-character-set = utf8
[mysqld]
character-set-server = utf8
[root @ localhost log] # mysql
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

and above are error messages and related files.
If i have any good advice, thank you.


Appendix

[root @ localhost ~] # su-mysql
/ usr/local/rbenv/libexec/rbenv-init: line 131: cannot create temp file for here-document: no free space on device
-bash-4.1 $