Home>

I started using Visual Studio code on Ubuntu 17.10. Immediately after introduction.
I was in a state where I could not input Japanese on VScode.
By the way, the input system uses fcitx-mozc, and it works normally with other software.
As for Japanese input, I couldn't get much useful information even in Google search under similar conditions.

Here are additional information items.
● Previously on the console
Visual Studio Code appears in Ubuntu with Snap package
I installed VScode directly from snap with reference to, but it didn't even start due to some trouble, so
After uninstalling with "snap remove", there is a history of formal re-installation from "Software" on Ubuntu.

I had a similar question on StackOverflow
VScode cannot be entered in Japanese
However, the situation did not change even after trying the solution described here.

Because we are beginners of Linux and StackOverflow, if you have any missing information or strange grammar, please professor.

※ Additional note on the same day
● After "snap remove" again, delete the cache configuration file under/home that was found with'* vscode *'and reinstall->meaningless
● Change the input method to iBus-mozc and restart your PC → Start → No meaning

In the reply to the question below, I mentioned re-installation of Linux itself.

* 4/16 added
It was solved. Thank you very much.

  • Answer # 1

    It's not a direct answer, but I don't think you should use Ubuntu 17.10 if you are new to Linux. Ubuntu has LTS (Long Term Support) released every two years and non-LTS released every six months in between, but recent non-LTS is an element of "experiment for the next LTS" Tend to be at the expense of stability. Not suitable for beginners.

    The previous LTS, 16.04 LTS, will be supported until April 2021, so why not try it back? In this environment, I have confirmed that VSCode + fcitx-mozc can input Japanese without problems.

    Since the next LTS 18.04 LTS is scheduled to be released on the 26th of this month, it may be one way to wait and use it, but it is better to use something that has been in operation for some time and has been "dead" to some extent. I think it can be expected in terms of stability.

  • Answer # 2

    In the previous question, it seems that you installed multiple VScodes (not sure), so aren't they?

    Well, there is an option to re-enter from Ubuntu when it is absolutely impossible.

  • Answer # 3

    I don't know the details because I haven't followed, but this is a bug caused by snap The solution is to use per apt or wait for the April release.

    Inability to use the input method on Ubuntu 17.10

    5458 # comment-376185785

  • Answer # 4

    As a result, it is not a snap version of VScode that can be installed with "software" and "snap install".
    Japanese input now works correctly by installing from the .deb package distributed by Microsoft official.
    I will personally consider what to do with Ubuntu version 17.10.

    We gave the best answer to keicha_hrs who gave us more detailed explanations.
    thank you everybody.

  • Answer # 5

    Ubuntu18.04 faced the same problem and solved it by installing the deb package distributed by MS.