Home>

We use CentOS7 with Sakura VPS.

When systemctl start sshd.service is executed,
Job for sshd.service failed because the control process exited with error code.See"sytemctl status sshd.service"and"journalctl -xe"for details.
Is displayed and rebooting does not work.

When I looked at status,
Fail to start OpenSSH server daemon.
Is displayed.
I thought this might be the cause, but I don't know how to solve it.

Thank you very much.

systemctl status sshd.service
When is executed, the following message is displayed.

sshd.service-OpenSSH server daemon
Loaded: loaded (/usr/lib/systemd/system/sshd.service;enabled;vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Wed 2018-04-18 12:02:23 JST;39s ago
Docs: man: sshd (8)
man: sshd_config (5)
Process: 1453 ExecStart =/usr/sbin/sshd -D $OPTIONS (code = exited, status = 255)
Main PID: 1453 (code = exited, status = 255)

Apr 18 12:02:23 ik1-336.vs.sakura.ne.jp systemd [1]: Failed to start Ope ...
Apr 18 12:02:23 ik1-336.vs.sakura.ne.jp systemd [1]: Unit sshd.service e ...
Apr 18 12:02:23 ik1-336.vs.sakura.ne.jp systemd [1]: sshd.service failed.
Hint: Some lines were ellipsized, use -l to show in full.

journalctl -xe
Will cause 3457 lines to be displayed
Please let me know if you have any good points.

journalctl -xe | grep sshd
Before and after "Failed to start" is displayed.
Thank you.

-
-Unit sshd.service has begun starting up.
Apr 18 12:19:17 ik1-336.vs.sakura.ne.jp sshd [1512]:/etc/ssh/sshd_config l
Apr 18 12:19:17 ik1-336.vs.sakura.ne.jp systemd [1]: sshd.service: main pro
Apr 18 12:19:17 ik1-336.vs.sakura.ne.jp systemd [1]: Failed to start OpenSS
-Subject: Unit sshd.service has failed
-Defined-By: systemd

-Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
  • Answer # 1

    /etc/ssh/sshd_config
    Line of ChallengeResponseAuthentication and GSSAPICleanupCredentials
    It was solved by commenting out.

  • Answer # 2

    Check the system log for errors.
    / var/log/messages
    / var/log/secure

  • Answer # 3

    Execute the following command, and don't miss it in the comment field ...

    yum reinstall openssh
    systemctl enable sshd
    systemctl start sshd